CCNA – Don’t forget “ip routing”

Just a quick note here – if you are reading the Lammle book Chapter 7 on IP Routing, you have no doubt run into his lab with the Corp, R1, R2, and R3 routers. We did and diligently followed the static routing examples – and of course routing did not work.

Remember – add ip routing to your configuration. Otherwise the ping commands he has in his lab simply won’t work.

In a different article we’ll discuss how we got Damn Small Linux running on VMware Workstation, built our virtual networks, and connected everything to our routers. For now, let’s close with the R3 router configuration from the lab.


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$GwL5$AeV0B8XZbhog3bB9gsK9G1
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.10.1 172.16.10.10
!
ip dhcp pool Admin
   network 172.16.10.0 255.255.255.0
   default-router 172.16.10.10
   dns-server 172.16.10.2
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description Connection to Corp Router
 ip address 10.1.5.2 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/0
 description WLAN for Mobile User
 ip address 172.16.10.10 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
banner motd ^C This is my R3 Router ^C
!
line con 0
 exec-timeout 0 0
 password console
 logging synchronous
 login
line aux 0
 password aux
 login
line vty 0 4
 password telnet
 login
line vty 5 871
 password telnet
 login
!
!
end

Team-oriented systems mentor with deep knowledge of numerous software methodologies, technologies, languages, and operating systems. Excited about turning emerging technology into working production-ready systems. Focused on moving software teams to a higher level of world-class application development. Specialties:Software analysis and development...Product management through the entire lifecycle...Discrete product integration specialist!

Tagged with: , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Human Verification: In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.